Jump to content
Simio Forum

Welcome to the Simio Forum

Welcome to the Simio Forum! Experience the full experience of the forum by becoming a Simio Insider! You must be an Insider to post on any forum!

Click_Here_button.png

New Software Release

Our latest release, Simio 11, is here!

SusanaAguiar

user defined add-ins

Recommended Posts

Hello everyone.

 

I'm new to Simio and I'm having trouble adding User Add-ins.

I'm using Simio 10.181.17705. When I click on the Project Home -> Select Add-In

It only shows "Source, Server, Sink" and nothing else, although there should appear other examples.

Any suggestion?

 

Thank you in advance.

 

 

Share this post


Link to post
Share on other sites

"Source, Server, Sink"  is the only default AddIn provided , you need to install other AddIn by your self( ie. putting dll files into simio user extensions folder )....

AddIns in Simio are powerful and flexible .

image.png.67bc0c50f6823d4eb0fed0e58e2b67d2.png

Best regards/Jeff

 

Share this post


Link to post
Share on other sites

Thank you for your quick reply.

 

I have added other dll examples to the user extensions folder but they never show up in the simio Add-in.

I'm using the Simio Personal Edition. Does the Add-in feature works in this version?

 

Thank you again for your help.

Best regards,

Susana 

 

Share this post


Link to post
Share on other sites
Quote

 

Simio Personal Edition can use those addIns...it is not a problem.

you may need to refer to posts in SI-API to see what is the default folder to put those dll in...

as I can remember, they are put into folders like: C:\Users\\Documents\SimioUserExtensions

 

Share this post


Link to post
Share on other sites

Hello.

I already did everything that it is suggested in related posts in SI-API. Including:

- placing the dll in C:\Users\\Documents\SimioUserExtensions

- placing the dll in \UserExtensions

- run the SimioApiHelper, which detects the dll and no error is detected.

- made sure all the files where unblocked

I'm not really sure what is going on, or what else to try.

Thank again for your help.

Share this post


Link to post
Share on other sites

Hello.

I had already tried that too.

 

I discovered something in the file SimioActions.log it shows the following messages for several files, including some that came with the installation. For example:

Cryptographic exception in loading 'C:\<path>\.\SimioUserExtensions\ImportObjectsAndLinksFromSpreadsheet\ImportObjectsAndLinksFromSpreadsheet.dll', message: 'Cannot find the requested object.
'
(10:27) [0133 MB] Did not have Simio permission to load 'C:\<path>\.\SimioUserExtensions\ImportObjectsAndLinksFromSpreadsheet\ImportObjectsAndLinksFromSpreadsheet.dll'
(10:27) [0133 MB] Cryptographic exception in loading 'C:\Program Files (x86)\Simio\.\UserExtensions\GoodSelectionProcedure\GoodSelectionProcedure.dll', message: 'Cannot find the requested object.
'
(10:27) [0133 MB] Did not have Simio permission to load 'C:\Program Files (x86)\Simio\.\UserExtensions\GoodSelectionProcedure\GoodSelectionProcedure.dll'

 

Any idea of what might be happening?

Thanks again for your help.

Share this post


Link to post
Share on other sites

I think the problem is not so hard. Contact with technical support (support@simio.com) they will solve this inconvenience quickly.  

Share this post


Link to post
Share on other sites

×
×
  • Create New...