Jump to content
Simio Forum

Welcome to the Simio Forum

Welcome to the Simio Forum! Experience the full experience of the forum by becoming a Simio Insider! You must be an Insider to post on any forum!

Click_Here_button.png

New Software Release

Our latest release, Simio 11, is here!

Elkherbawy

Some problems with Simio results

Recommended Posts

Hello everyone,


I made a simple model for road project (only 4 activities each has a vehicle as resource); with reference to Simio example: Introduction to Simulation and Scheduling, as can be seen in the attached file. However, I have some illogical results, first of these results in case of activities utilizations there values are near to 100% as there expressions are: Vehicle.Capacity.ScheduledUtilization. Second, Throughput and Stability values are by zero due to NumberDestroyed are by zero while I made Destroyable (which is in Population for Model Entity) as True.


Thanks in advance,

Ahmed Elkherbawy

Model 1.spfx

Share this post


Link to post
Share on other sites

1. If you look at the results in the pivot grid for your vehicle, you will see that the Resource State Time Offshift Busy is very high. This means your Vehicles are still processing (utilized) after they went offshift. Scheduled utilization is based on how long the Resource is utilized vs how long the Resource is scheduled to be onshift. By default, Resources finish processing their current entity before going offshift, during this in bewtween time it is a state called OffshiftBusy. You have to put additional logic if you want something different to occur. Look into the Interrupt or Suspend/Resume steps.

2. None of your Entities are Destroyed. There is no Sink object in the Pivot Grid because no entities ever enter it (usually it is shown in the pivot grid). If you look in Trace, you'll see that none of the Entities are ever sent to the Sink. The entities are routed using a Sequence Table, but the Sequence Table does not have a row for Input@Finished...The sequence restarts if it gets to the end of the sequence.

Share this post


Link to post
Share on other sites

Hello,


First of all, I am really very thankful for your replying and concerning. I made some changes on my model but there are still some problems:


1. Resources Utilisation have very high percentages!! However I added row for Input@Finish but still NumberDestroyed by Zero!!

2. In case of "AvgQPR1 & 2" meaning the average of all QPRs during runs, how can I identify AvgQPRs by this meaning?!

3. TotalQPRs meaning: as these two activities should repeat for 65 times till their works finish TotalQPRs are their summations (for example TotalQPR = QPR1*65 = 162*65 = 10530 cubic meter); how can I make this rule.

4. Finally, the percentage of throughput is very low, how can I show this percentage in more realistic?!


Looking forward to hearing from you and thanks again.


All the best,

Ahmed Elkherbawy

Model 1b.spfx

Share this post


Link to post
Share on other sites

Hello Ahmed,


First, you have your vehicle network only. And there aren't enough paths or links for it to travel on in the correct directions. I would set it to network if possible for now until you resolve this and you have some of your nodes with Outbound Travel Mode set to Network Only. But the vehicle is having the most issues with the fact that it is being required to be in two places at once and the processing of the entity at the servers will never complete. The first entity goes into the Unloading Server. You have it being moved as a secondary resource to the input node at the server in your task requirements. Then, you have the server itself requiring the AggregateTipperTruck to move to the output node as it is required. The resource capacity for the vehicle can be seized twice and successfully complete processing at the server. I hope this helps point you in the right direction.




Judy

Share this post


Link to post
Share on other sites

Dear Judy,


First of all thanks for your reply. Secondly, I attached to you another version of the model after I made some modifications. It can be seen in the model, I named a new server as Section 1 and added into it two tasks (Unloading and Leveling, they were servers in previous model) each has its resource (vehicle). I used only one entity for the two tasks.


Section 1 will have total Quantity by 2031.25m3 (Which means the total amount of material, since a truck will unload this material and a grader will level it on the surface). The total length of this server (Section 1) is 200 meters as in real life. For the first resource "Aggregate Tipper Truck", its total number is NumAggTr = 20, its rate per hour is named as QSTTRate (has random value), its total number of trips to finish works is TTS = 113 and quantity in each trip is named as QSTT (has also random value). While for the other resource "Grader", its total number is NumGr = 2, its rate per hour is named as QSTGRate (has random value), its total number of trips to finish works is GTS = 32 and quantity in each trip is named as QSTG (has also random value). Since the previous expressions will increase with acceleration, so I inserted Level With Acceleration for each of them to be used as state variable into Finish (Sink). Finally, PPCQSTT and PPCQSTG are the productivity of each task.


I have 5 inquiries and they are:


1- Why the resources did not make the appropriate distance travelling? For example, the number of "Aggregate Tipper Truck" is 20 and total number of trips are 113 so each should make about 6 trips (113/20), since the length of Section 1 is 200 meters, then each should make 1200 meters (200*6).


2- In table which named "Sub-Activity Schedule", if I change the value under "Scheduled Finish Date" column the value under Actual Finish Date will change. Why this occurred and why "Status" never be "Ahead" or "On Time"?


3- How can I calculate the values of PPCQSTT and PPCQSTG Daily or Weekly?


4- If I want to identify constraints into each task, how can I do that?


5- How can I apply the concept of Look-Ahead Planning (Daily or Weekly), to remove the added constraints?


Thank you again


Best regards,

Ahmed Elkherbawy

Model 1.spfx

Share this post


Link to post
Share on other sites

Hello Ahmed,


You still have your vehicles set to Network only. But there aren't any paths/networks to follow at all for it. It can't travel from one place to the other without them. Therefore, distance traveled is 0. You could place two nodes at each end of the server and have your vehicles move back and forth between those in free space. You'd have to set your vehicles' initial travelmode to Freespace Only.


Next, you have some issues with your logic. Entities are trying to seize the resources/vehicle. You have your tasks set to seize SomeProperty.HasValue. The .HasValue only checks to see if there is a value in the property. Which it does. But the check is more like a Boolean. 1 or 0. It is not a value or quantity. Then you have the number of units of capacity for each vehicle only set to 1 because work schedule. Which is fine. But even if you take the .HasValue off, you are trying to seize more units of capacity than one. Since your vehicles never have that capacity (remember ride capacity and resource capacity are different things) your order will never finish processing and will always be behind. I would worry about the logic of your model. I have modified your model to over simplify things. Which I recommend doing first. Then building upon that. Get an entity to travel from the start to finish before adding lots of other factors in.


In the modified model (saved in10.165) , you can see that you have set a Target. The Scheduled finish date versus the actual finish date are tied together.

As far as constraints, you will see that in the Planning tab, after running the Create Plan button, there is under the Tasks of Section1 where the Constraints are shown. See image. In this case, it's the resource arrival of a vehicle.


I hope this information helps.


Thank you,


Judy

Constraints1.PNG.1ba8f1aeed222c1096009d05706e632b.PNG

Model 1 Modified.spfx

Share this post


Link to post
Share on other sites

Hello Judy,


Thanks for your modifications, I edited the model with these comments. I have some concerns, first, by applying Standard Dispatching Rule, Is it minimise the processing time of task, and I do not know how to run the simulation by using a new network with vehicles.


Best regards

Ahmed Elkherbawy

Share this post


Link to post
Share on other sites

×
×
  • Create New...