Jump to content
Simio Forum

Welcome to the Simio Forum

Welcome to the Simio Forum! Experience the full experience of the forum by becoming a Simio Insider! You must be an Insider to post on any forum!

Click_Here_button.png

New Software Release

Our latest release, Simio 11, is here!

felipehidalgob

Error "Wating to Transfer Into Station"

Recommended Posts

I’m representing an empty container deposit, where the containers are stored in different blocks. Gate in trucks arrives to the deposit loaded with containers that have to be unloaded by cranes and stored in the container blocks. In addition, there are gate out trucks that arrive to the deposit to retrieve containers.


In the model, the containers are represented as entities, so as the trucks. I use Stations to represent the blocks that store the containers.

To understand the logic of container arrival, we have to notice that next to the Station there is a Transfer Node, and when a container enters the Node (through a Transfer step in a Process), is transferred to the Station.


To understand the logic of container retrieval, we have to notice that there is a Combiner next to the Station, and when the truck enters the Parent Input Combiner Node, a Process is triggered that searches for the container in the corresponding Station, and then it to the Member Input Combiner.

Given that there is one Station for one block of containers, a single Station is used for the arrival and the retrieval of containers.


The problem that I have is that in certain occasions, when a container is going to enter a Station, an error occurs and Simio shows this message: “The entity location is in transition state “WaintingToTransferIntoStation” and a new transfer request is invalid”. I don’t understand why this happens, given that in the Node that triggers the Process that executes the Transfer, only a single container enters at a time.


Captura%20de%20pantalla%202016-05-31%20a%20las%2012.51.17%20a.m..png


Any help is greatly appreciated!


Release: 8.136.13569


Model is attached.


https://dl.dropboxusercontent.com/u/41163946/ModelPlacillaNewV3.spfx

Share this post


Link to post
Share on other sites

Cant open the model (please next time tell us that you use academic version).

But from my experience this Error is caused by entity haven't end its transfer step.

If you use transfer into station you must create proces mystation_entered triggered by mystation_entered_event and place EndTransfer step there.

Otherwise entity hangs in WaitingFor transfer state.


The other possibility is that another process is already dealing with this entity and is transfering it. This sometimes happen if you search queue or station for entities and try to transfer them. If you don't check carefully for entities already beeing transfered, you get this message.

Share this post


Link to post
Share on other sites

×
×
  • Create New...